TOPIC: Persistent Set ? error
#210
Persistent Set ? error 4 Years, 3 Months ago
Hello,
When a persistent set is made and run using the command suneido pers_set from DOS prompt, it runs fine. But when the same shortcut is used a second time, the persistent set does not come up correctly- just a small window with title bar and the standard buttons come up. I am missing something?
ajith
 
 
#213
Re:Persistent Set ? error 4 Years, 3 Months ago
Hi Ajith,

I just tested one of my own persistent sets and it works when I run it multiple times. You could try deleting that set from the persistent table (delete based on the "set" field), then create a new set using PersistentWindow. Make sure all of the necessary libraries are in use when you create the new set.
 
 
Jeff Ferguson
Suneido Software
 
#216
Re:Persistent Set ? error 4 Years, 3 Months ago
Hello Jeff,
Thanks for your help. I had forgotten to use the library.
ajith
 
 
#221
Re:Persistent Set ? error 4 Years, 3 Months ago
Hello,

The error is present even now! Try with a compiled library.

ajith
 
 
#223
Re:Persistent Set ? error 4 Years, 3 Months ago
Hi Ajith,

I tested a simple example and it worked with the source code library, but not with the compiled library. The reason for this is that the PersistentWindow class is not getting the right class name from the compiled library for the control. We'll have to check into this. For now, I guess you'll have to use the library with the source code in it if you want to use a persistent set.
 
 
Jeff Ferguson
Suneido Software
 
#288
Re:Persistent Set ? error 4 Years, 1 Month ago
Hello,
Any fix?
ajith
 
 
#290
Re:Persistent Set ? error 4 Years, 1 Month ago
Sorry, there is no fix available yet.
 
 
Jeff Ferguson
Suneido Software
 
#293
Re:Persistent Set ? error 4 Years, 1 Month ago
Sorry, I have not got around to looking at this. We do not use compiled libraries so this has not been a problem for us.
 
 
andrew