TOPIC: nonexistent 'lib_committed' ?
#452
nonexistent 'lib_committed' ? 3 Years, 9 Months ago
Hello Andrew, et al.

Been a while...

Just installed 20 Mar 2006 (.exe) onto an AMD Turion 64 x2 box running XP MCE SP2 (32 bit) and was running through getting started since it's been a while.

I got to creating a new book, and when I made a new item I got the debug dialog (see attached -- or not, since it's too big) saying 'lib_committed' was a non-existent column. Say what? This happened when I tried to type in a new name. Also, I can't remember whether right-click is supposed to fly out a context menu in Book Edit; it surely does not in this install on this machine.

I'm lost.

I'd added a bunch of other stuff the first time I tried to post this, but the forum logged me off before I submitted, so I'll save all that for later.

--kevin kinnell

Post edited by: kejoki, at: 2006/11/27 06:11


    Post edited by: kejoki, at: 2006/11/27 06:14
     
     
    #453
    Re:nonexistent 'lib_committed' ? 3 Years, 9 Months ago
    Hi Kevin,

    I was pretty sure this problem had come up before but searching the forum for lib_committed only found your post.

    Looking at the version control I see we made one fix related to this in BookEditModel update:

    Code:

    if (x.oldname isnt x.name)
        {
        // "delete" old name
        if TableExists?('svc_deleted')
           try QueryDo('insert ' $ .table $



    The change is the added "try". (I usually don't like to use "try" this way because it can "hide" other errors. It would be better to check if lib_committed existed.)

    No context menu on the tree in BookEdit - no one has got around to it, I guess.

    Post edited by: andrew, at: 2006/11/27 15:27
     
     
    andrew
     
    #456
    Re:nonexistent 'lib_committed' ? 3 Years, 8 Months ago
    Thanks, Andrew.

    That took care of it.

    I'm a little baffled that it hasn't come up more often.

    --kk